Introduction to MINITAB

What is MINITAB?

MINITAB is a powerful, easy-to-use, statistical software package that provides a wide range of basic and advanced data analysis. MINITAB for Windows provides a user interface that makes statistical analysis more intuitive for all levels of users. Pull-down menus and dialog boxes give you easy prompts every step of the way. You just double-click on the program icon, and off you go! MINITAB lets you spend more time exploring your data and less time telling the computer what you want it to do. Data may be entered into a spreadsheet like window. There is also the option of importing data directly from Lotus, Excel, dBase, or ASCII files with MINITAB's importing/exporting capability. With MINITAB's (Rel 10 and higher) Dynamic Data Exchange (DDE) you can enter your data into another spreadsheet program, such as Lotus, Excel and MINITAB will receive it automatically. Or, you can enter data into MINITAB and send it simultaneously to another Windows program. MINITAB's graphics capability gives you unlimited possibilities to get the maximum visual impact. The macros let you create your own custom operations, designed specifically for your applications.

Some of the capabilities of MINITAB for Windows include:

- **General**: Windows menu interface, interactive command-line option, context-sensitive HELP, and powerful macro programming language.
- **Data and File Management**: Importing/Exporting, Dynamic Data Exchange, data editor, data manipulation, merge worksheet, logical operators, arithmetic operators, matrix functions including transpose, inverse, eigenvalues, and eigenvectors.
- **Basic statistics**: descriptive statistics, confidence intervals, cross tabulations, correlation and covariance matrices, and test of homogeneity of variances.
- **Advanced statistics**: regression, ANOVA, cluster analysis, factor analysis, nonparametric procedures, time series analysis, simulations and distributions.
- **Graphics**: presentation-style graphics, and ability to edit graphs. Plots and charts, 3D surface plot, scatterplot.
How to start a MINITAB session

Take the following steps to start a MINITAB session under Windows.

- Click Start button -> Program -> MINITAB 13 -> MINITAB.

A MINITAB window will open showing the MINITAB – Untitled with a menu bar. Another two windows, Session and Worksheet, also appear within the larger window.

Orientation

The interface

There are five different window types in MINITAB for Windows accessible from the Main menu Window option.

- Session window: The Session window displays the text output generated by your analyses and other work. It also contains a record of all the commands you have issued in the current session. You can display the command language used to create the output, and type Session commands in at the active MTB> prompt. To enable Commands, choose Enable commands from Editor menu.
- Project Manager windows: The Project Manager contains folders that allow you to navigate, view, and manipulate various parts of your project.
• **Worksheet window**: The Worksheet window displays your data in a row-by-column format. You enter data from the keyboard or retrieve data into this window.

• **Help window**: The Help window contains information on using MINITAB.

• **Graph window**: The Graph window displays high-resolution graphs by MINITAB's Graph command. This window becomes available only after you generate graphical output.

**Menus**

When you start a MINITAB session under Windows, the top strip of the window contains the main menus: **File, Edit, Manip, Calc, Stat, Graph, Editor, Window** and **Help**.

**Help during MINITAB computing**

Help is available at every step of MINITAB computing. Use the Help menu for help on any topic. Also context-sensitive help is available with each dialog box. If you don't understand what an item in a dialog box is for, click the ? button, or press F1 for an explanation of the item.

### Getting Started

**Organizing your data for analysis**

MINITAB uses data organized in row and columns. The rows are **cases**, and the columns are **variables**. MINITAB automatically numbers columns in the worksheet as C1, C2, and so on. A MINITAB worksheet can contain up to 4000 columns, and as many rows as your worksheet size will allow.

<table>
<thead>
<tr>
<th>Name</th>
<th>Test1</th>
<th>Test2</th>
<th>Test3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tim</td>
<td>20</td>
<td>23</td>
<td>24</td>
</tr>
</tbody>
</table>


MINITAB handles three types of data:

1. Numeric (numbers), Numeric missing value (*)
2. Text (characters that can consist of a mix of letters, numbers, spaces, and special characters), Text missing value (blank)
3. Date/Time (dates, times or both).

MINITAB determines the type of a variable based on the first row of the column. A numeric variable will only have numbers as values. Each text variable can have a maximum of 80 characters (letters, numbers, punctuation symbols, blanks). Upper and lower case character values in a variable are differentiated.

If you want to use text data in a place where only numeric data are supported, you can use the Code command in the Manip menu to convert text values into numeric values.

The numbers stored in numeric variables can have up to 15 or 16 digits. You can use a negative (-) sign for negative numbers. MINITAB reads numbers with decimal points or exponential notation.

Even though MINITAB automatically assigns a column number for each variable in the worksheet, you may assign a unique name for each variable. A variable name (column name) can contain up to 31 characters, with no leading or trailing spaces, no single quotation marks ('), and no octothorpes (#). A name cannot consist of a single asterisk (*). A variable can be addressed with its column number or the name you assign to it.

Numeric missing value is flagged by a * and by a blank for text (formerly called alpha) variable.

**Entering data into worksheet**

Move the cursor to the cell immediately below the cell labeled C1 and type **id** and press TAB. Now the cursor moves to the cell below the cell labeled C2. Type in **sex** and press the TAB key. Type in the remaining three variables, **test1, test2** and **test3** under columns C3, C4, and C5.

Instead of using the TAB key for moving to the next cell, you could use the ENTER key. However, the ENTER key moves the cursor in the direction of the
data entry arrow shown in the top left corner of the Data window. You can change the direction of this arrow by clicking on it.

Creating a new variable

- From the Calc menu select Row Statistics...
- Select Mean from the options appearing in the dialog box.
- Click on the box below the Input variables: Now the variables in your data set will appear in the box on the left of the dialog box.
- Type in test1 test2 test3 (or select them from the variable list).
- Click on the box to the right of Store result in:
- Type in average.
- click OK.
Now, suppose you want no decimal points for the new variable in column 6.

- Move the pointer to column 6, which is the variable named **average** and click on the cell labeled C6 to highlight the variable column.
- Select **Format Column/Numeric** from Editor menu.
- Select **Fixed decimal width** and type 0 in the box right to it. (Note that this affects only the way the numbers are displayed in the data window, but not how the values are stored.)
- Click **OK**.

**Save the data file**

- Select **Save Current Worksheet As...** from the **File menu**. A dialog box appears.
- Type `c:\ex1.mtw` as filename
- Click **OK**.
Exporting a data file in ASCII (text) format

• Select New... from the File menu, and choose Minitab Worksheet from appeared dialog box, then click OK.
• From the File menu select Other Files/Export Special Text....
• Specify C1-C5 as the columns to store the data.
• Click OK.
• Type c:\ex1.dat as filename

Reading a data file in ASCII (text) format

In some situations, you may have created a data file using other software applications (e.g., Excel, Lotus), a data editor, or a word processor. In such a situation, you do not have to enter your data again into the Worksheet. You can import such files into MINITAB. In the example below, we are going to import an ASCII data file into MINITAB worksheet. MINITAB can read ASCII data in free-format (each value is separated by at least one space, or comma, without any blank cells, and no text variables), and fixed format (each value appears in the same place for every case). Text variables also can be imported using fixed format.

To import the data into MINITAB:

• Select New... from the File menu, and choose Minitab Worksheet from appeared dialog box, then click OK.
From the **File** menu select **Other Files/Import Special Text**.

A **Import Special Text** dialog box appears.

- Specify **C1-C5** as the columns to store the data.
- Click **OK**.

![Import Special Text dialog box](image)

Another dialog box appears titled **Import Text from File**.

- Type **c:\ex1.dat**. (You may use the mouse to select the file.)
- Click **OK**.

If your data is entered without a blank space between the variables you may read it into MINITAB using fixed format style. To import ASCII data involving text variables use the fixed format. Suppose in the above ASCII data file, c:\ex2.dat, the variable sex was given as a text variable (1=F, 2=M) as shown below.

<table>
<thead>
<tr>
<th>01</th>
<th>F</th>
<th>838591</th>
</tr>
</thead>
<tbody>
<tr>
<td>02</td>
<td>F</td>
<td>657268</td>
</tr>
<tr>
<td>03</td>
<td>M</td>
<td>607464</td>
</tr>
<tr>
<td>04</td>
<td>M</td>
<td>889692</td>
</tr>
<tr>
<td>05</td>
<td>M</td>
<td>847982</td>
</tr>
<tr>
<td>06</td>
<td>F</td>
<td>909490</td>
</tr>
</tbody>
</table>
To import the file:

- From the **File** menu select **Other Files/Import Special Text...**
- Specify C1-C5 as the columns to store the data.
- Click **Format**...
- Click **User-specified format** from the dialog box titled **Import Special Text - Format**.
- Type in `F2,A1,F2,F2,F2` or `F2,A1,3F2`
- Type `c:\ex2.dat`. (You may use the mouse to select the file.)
- Click **OK**.

### Reading a data file in some formats:

- Minitab(*.mtw)
- Excel(*.xls)
- Text(*.txt; tab delimited file)
- Data(*.dat; tab delimited file)

- From the **File** menu select **Open Worksheet...**
• Type `c:\ex1.xls`. (You may use the mouse to select the file.)
• Click OK.

**Descriptive Statistics**

To run the descriptive statistics:

• From the **Stat** menu select **Basic Statistics**. From **Basic Statistics** select **Display Descriptive Statistics**. Select **test1, test2, test3, and average** for variables. The variables appear in the box on the right.
• Click OK.

The output from the commands you just executed appears on the screen as shown below.

![Descriptive Statistics: test1, test2, test3, average](image)

The number of decimal places in the output cannot be tailored through any menu options in MINITAB. However, you may edit the Session window. To edit the output select **Editor/Output Editable**.

**Printing output**
Once you are satisfied with your analysis you may want to obtain a hard copy of the output. You may print the entire output or selectively delete unwanted portion of the output before printing, or select the part you want and then print that part. You may also save the output file (File/Save Session Window As... from the Session window) into files on your drive (or where directed) for later use.

To print the output from the Session window:

- Select Print Session Window... from the File Menu.
- Click OK at the print dialog box.

The contents of the window will now be printed.

**Using MINITAB’s Graph menu**

MINITAB provides a wide selection of graphics for every stage of your project: exploration, research, and presentation.

Plotting 2 variables using the Graph menu

- Select Graph/Plot...

To print the plot from the graph window:

- Select File/Print Graph...
- Click OK.

To save the plot from the graph window:

- Select Save Graph As...
- Type c:\Graph1.JPG. (You may use other types of Graphic files. E.g., Minitab graph (*.MTF), JPEG 24 bit color (*.JPG), TIF color (*.TIF), and so on.)
- Click OK.

Reference:

The documents are from Stat/Math center in Indiana University